Search & Replace <= 3.2.1 - Authenticated (Administrator+) SQL injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2024-4145
CVSS 7.2 (High)
Publicly Published May 23, 2024
Last Updated June 18, 2024
Researcher Krugov Artyom


The Search & Replace plugin for WordPress is vulnerable to SQL Injection via the select_tables parameter in all version up to, and including, 3.2.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Search & Replace

Software Type Plugin
Software Slug search-and-replace (view on
Patched? Yes
Remediation Update to version 3.2.2, or a newer patched version
Affected Version
  • <= 3.2.1
Patched Version
  • 3.2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.