Sell Media <= 2.5.5 - Cross-Site Request Forgery Bypass

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-4420
CVSS 4.3 (Medium)
Publicly Published August 16, 2021
Last Updated January 22, 2024
Researcher Jerome Bruandet - NinTechNet


The Sell Media plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.5. This is due to missing or incorrect nonce validation on the sell_media_process() function. This makes it possible for unauthenticated attackers to sell media paypal orders via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Sell Media

Software Type Plugin
Software Slug sell-media (view on
Patched? Yes
Remediation Update to version 2.5.6, or a newer patched version
Affected Version
  • <= 2.5.5
Patched Version
  • 2.5.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.