Shortcodes Ultimate <= 5.12.6 - Authenticated (Subscriber+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2023-23800
CVSS 6.5 (Medium)
Publicly Published February 10, 2023
Last Updated February 16, 2023
Researcher Rafie Muhammad - Patchstack


The Shortcodes Ultimate plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 5.12.6. This is due to insufficient validation on the url being supplied via the "url" attribute of the su_csv_table shortcode. This makes it possible for authenticated attackers, with subscriber-level privileges and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



1 affected software package

Software Type Plugin
Software Slug shortcodes-ultimate (view on
Patched? Yes
Remediation Update to version 5.12.7, or a newer patched version
Affected Version
  • <= 5.12.6
Patched Version
  • 5.12.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.