Shortcodes Ultimate <= 5.12.6 - Authenticated (Subscriber+) Arbitrary File Read via Shortcode

External Control of File Name or Path
CVE CVE-2023-25050
CVSS 6.5 (Medium)
Publicly Published February 10, 2023
Last Updated February 14, 2023
Researcher Rafie Muhammad - Patchstack


The Shortcodes Ultimate plugin for WordPress is vulnerable to Arbitrary File Read in versions up to, and including, 5.12.6. This is due to insufficient validation on the url being supplied via the "url" attribute of the su_table shortcode. This makes it possible for authenticated attackers, with subscriber-level privileges and above, to supply paths to arbitrary files that will be returned when rendering the shortcode. This can be leveraged to read sensitive configuration files like wp-config.php. This is only exploitable when the Unsafe features option is enabled.

Wordfence blocked 23 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug shortcodes-ultimate (view on
Patched? Yes
Remediation Update to version 5.12.7, or a newer patched version
Affected Version
  • <= 5.12.6
Patched Version
  • 5.12.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.