WP Shortcodes Plugin — Shortcodes Ultimate <= 5.13.3 - Insecure Direct Object Reference to Information Disclosure

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-6226
CVSS 4.3 (Medium)
Publicly Published November 27, 2023
Last Updated January 22, 2024
Researcher Francesco Carlucci


The WP Shortcodes Plugin — Shortcodes Ultimate plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.13.3 via the su_meta shortcode due to missing validation on the user controlled keys 'key' and 'post_id'. This makes it possible for authenticated attackers, with contributor-level access and above, to retrieve arbitrary post meta values which may contain sensitive information when combined with another plugin.



1 affected software package

Software Type Plugin
Software Slug shortcodes-ultimate (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.0.0, or a newer patched version
Affected Version
  • <= 5.13.3
Patched Version
  • 7.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.