Simple Googlebot Visit <= 1.2.4 - Missing Authorization to Settings Update

Missing Authorization
CVE CVE-2023-38479
CVSS 4.3 (Medium)
Publicly Published July 24, 2023
Last Updated February 8, 2024
Researcher Abdi Pranata


The Simple Googlebot Visit plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings() function hooked via a nopriv AJAX action in versions up to, and including, 1.2.4. This makes it possible for unauthenticated attackers to update the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug simple-googlebot-visit (view on
Patched? Yes
Remediation Update to version 1.2.5, or a newer patched version
Affected Version
  • <= 1.2.4
Patched Version
  • 1.2.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.