simple-git < 3.16.0 - Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2022-25860
CVSS 8.1 (High)
Publicly Published February 23, 2023
Last Updated February 23, 2023


The package simple-git is vulnerable to Remote Code Execution in versions before 3.16.0 via the clone(), pull(), push() and listRemote() methods due to improper input sanitization. This is due to an incomplete fix of CVE-2022-25912. WordPress plugins and themes may be using this package, however, they may not be vulnerable to exploitation.



1 affected software package

Software Type Plugin
Software Slug simple-local-avatars (view on
Patched? Yes
Remediation Update to version 2.7.4, or a newer patched version
Affected Version
  • <= 2.7.3
Patched Version
  • 2.7.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.