Simple Membership WP user Import <= 1.7 - Authenticated (Admin+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-0254
CVSS 7.2 (High)
Publicly Published January 12, 2023
Last Updated January 12, 2023
Researcher Etan Imanol Castro Aldrete


The Simple Membership WP user Import plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter in versions up to, and including, 1.7 due to insufficient escaping on the user supplied parameter. This makes it possible for authenticated attackers with administrative privileges to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Simple Membership WP user Import

Software Type Plugin
Software Slug simple-membership-wp-user-import (view on
Patched? Yes
Remediation Update to version 1.8, or a newer patched version
Affected Version
  • <= 1.7
Patched Version
  • 1.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.