Simple Membership <= 4.1.2 - Membership Privilege Escalation

Improper Privilege Management
CVE CVE-2022-2273
CVSS 8.8 (High)
Publicly Published July 6, 2022
Last Updated January 19, 2023
Researcher Jet Infosystems


The Simple Membership plugin for WordPress is vulnerable to membership related privilege escalation in versions up to, and including, 4.1.2. This is due to insufficient validation on the membership membership_level supplied which makes it possible for authenticated users to supplied arbitrary membership levels and be granted to permissions.



Vulnerability Details for Simple Membership

Software Type Plugin
Software Slug simple-membership (view on
Patched? Yes
Remediation Update to version 4.1.3, or a newer patched version
Affected Version
  • <= 4.1.2
Patched Version
  • 4.1.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.