Simple Membership <= 4.3.4 - Privilege escalation via Registration

Improper Input Validation
CVE CVE-2023-41957
CVSS 7.3 (High)
Publicly Published September 25, 2023
Last Updated September 27, 2023
Researcher Rafie Muhammad - Patchstack


The Simple Membership plugin for WordPress is vulnerable to privilege escalation due to missing input validation on the create_swpm_user function in versions up to, and including, 4.3.4. This makes it possible for unauthenticated attackers to register users with arbitrary membership levels. Since membership levels can be granted a higher user role than subscriber, this can lead to privilege escalation



Vulnerability Details for Simple Membership

Software Type Plugin
Software Slug simple-membership (view on
Patched? Yes
Remediation Update to version 4.3.5, or a newer patched version
Affected Version
  • <= 4.3.4
Patched Version
  • 4.3.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.