TaxoPress <= 3.6.4 - Authenticated (Editor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-2169
CVSS 5.5 (Medium)
Publicly Published April 18, 2023
Last Updated April 19, 2023
Researcher Ivan Kuzymchak - Wordfence


The TaxoPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Related Posts functionality in versions up to, and including, 3.6.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with Editor+ permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WordPress Tag, Category, and Taxonomy Manager – AI Autotagger

Software Type Plugin
Software Slug simple-tags (view on
Patched? Yes
Remediation Update to version 3.6.5, or a newer patched version
Affected Version
  • <= 3.6.4
Patched Version
  • 3.6.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.