NextScripts: Social Networks Auto-Poster <= 4.4.3 - Authenticated(Subscriber+) Sensitive Information Exposure

Exposure of Sensitive Data Through Data Queries
CVE CVE-2024-2088
CVSS 8.5 (High)
Publicly Published May 21, 2024
Last Updated May 22, 2024
Researcher Colin Xu


The NextScripts: Social Networks Auto-Poster plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.4.3 via the 'nxs_getExpSettings' function. This makes it possible for authenticated attackers, with subscriber access and above, to extract sensitive data including social network API keys and secrets.



Vulnerability Details for NextScripts: Social Networks Auto-Poster

Software Type Plugin
Software Slug social-networks-auto-poster-facebook-twitter-g (view on
Patched? Yes
Remediation Update to version 4.4.4, or a newer patched version
Affected Version
  • <= 4.4.3
Patched Version
  • 4.4.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.