Sparkle Demo Importer <= 1.4.7 - Missing Authorization to Authorized(Subscriber+) Post/Pages/Attachements Deletion and Demo Data Import

Missing Authorization
CVE CVE-2024-6120
CVSS 6.5 (Medium)
Publicly Published June 21, 2024
Last Updated June 21, 2024
Researcher Lucio Sá


The Sparkle Demo Importer plugin for WordPress is vulnerable to unauthorized database reset and demo data import due to a missing capability check on the multiple functions in all versions up to and including 1.4.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete all posts, pages, and uploaded files, as well as download and install a limited set of demo plugins.



Vulnerability Details for Sparkle Demo Importer

Software Type Plugin
Software Slug sparkle-demo-importer (view on
Patched? Yes
Remediation Update to version 1.4.8, or a newer patched version
Affected Version
  • <= 1.4.7
Patched Version
  • 1.4.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.