SpeedyCache <= 1.1.3 - Missing Authorization to Plugin Options Update

Missing Authorization
CVE CVE-2023-6598
CVSS 4.3 (Medium)
Publicly Published December 16, 2023
Last Updated January 22, 2024
Researcher Lucio Sá


The SpeedyCache plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the speedycache_save_varniship, speedycache_img_update_settings, speedycache_preloading_add_settings, and speedycache_preloading_delete_resource functions in all versions up to, and including, 1.1.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to update plugin options.



Vulnerability Details for SpeedyCache – Cache, Optimization, Performance

Software Type Plugin
Software Slug speedycache (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.4, or a newer patched version
Affected Version
  • <= 1.1.3
Patched Version
  • 1.1.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.