Spiffy Calendar <= 4.9.1 - Authenticated (Contributor+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-46859
CVSS 8.8 (High)
Publicly Published December 16, 2022
Last Updated January 22, 2024
Researcher Justiice


The Spiffy Calendar plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter among others in versions up to, and including, 4.9.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level permissions and above (or subscriber-level permissions, if the 'Event manager role' option is set to 'Subscriber'), to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



1 affected software package

Software Type Plugin
Software Slug spiffy-calendar (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.9.2, or a newer patched version
Affected Version
  • <= 4.9.1
Patched Version
  • 4.9.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.