Sponsors Carousel <= 4.02 - Authenticated (Admin+) Stored Cross-Site Scripting in show

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-23808
CVSS 4.4 (Medium)
Publicly Published February 20, 2023
Last Updated January 22, 2024
Researcher Rio Darmawan - Zerobyte


The Sponsors Carousel plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the an image title in versions up to, and including, 4.02 due to insufficient input sanitization and output escaping on the show function. This makes it possible for authenticated attackers, with administrator-level privileges, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.



Vulnerability Details for Sponsors Carousel

Software Type Plugin
Software Slug sponsors-carousel (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 4.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.