Stock Sync for WooCommerce <= 2.3.2 - Missing Authorization

Missing Authorization
CVE CVE-2022-46807
CVSS 4.3 (Medium)
Publicly Published March 22, 2023
Last Updated March 29, 2023
Researcher Cat


The Stock Sync for WooCommerce plugin for WordPress is vulnerable to unauthorized use of AJAX actions due to a missing capability check on the functions check_api_access and view_last_response in versions up to, and including, 2.3.2. This makes it possible for authenticated attackers with subscriber-level access, and above, to utilize those functions.



Vulnerability Details for Stock Sync for WooCommerce

Software Type Plugin
Software Slug stock-sync-for-woocommerce (view on
Patched? Yes
Remediation Update to version 2.4.0, or a newer patched version
Affected Version
  • <= 2.3.2
Patched Version
  • 2.4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.