Stock Ticker <= 3.23.0 - Missing Authorization via AJAX actions

4.3
Missing Authorization
CVE CVE-2023-27626
CVSS 4.3 (Medium)
Publicly Published March 13, 2023
Last Updated January 22, 2024
Researcher Mika

Description

The Stock Ticker plugin for WordPress is vulnerable to unauthorized settings update due to a missing capability check on several AJAX actions in versions up to, and including, 3.23.0. This makes it possible for unauthenticated attackers to change plugin settings.

References

Share

1 affected software package

Software Type Plugin
Software Slug stock-ticker (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.23.1, or a newer patched version
Affected Version
  • <= 3.23.0
Patched Version
  • 3.23.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation