Stop Referrer Spam <= 1.3.0 - Cross-Site Request Forgery via processParameters

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-33207
CVSS 5.4 (Medium)
Publicly Published May 18, 2023
Last Updated May 26, 2023
Researcher Mika


The Stop Referrer Spam plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.3.0. This is due to insufficient nonce validation on the processParameters function. This makes it possible for unauthenticated attackers to refresh the spam blocklist and save custom URLs via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The issue was partially patched in version 1.3.0 but because nonce generation does not occur until the first time the admin page is visited, it is possible for an attacker to supply an empty nonce value which will successfully result in settings being saved if the administrator has not yet visited the plugin's admin page.



1 affected software package

Software Type Plugin
Software Slug stop-referrer-spam (view on
Patched? Yes
Remediation Update to version 1.3.1, or a newer patched version
Affected Version
  • <= 1.3.0
Patched Version
  • 1.3.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.