Stop Spammers Security <= 2022.5 - Unauthenticated PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2022-4120
CVSS 9.8 (Critical)
Publicly Published December 5, 2022
Last Updated December 9, 2022
Researcher Seryeon Ham


The Stop Spammers Security plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2022.5 via deserialization of untrusted input when issuing a CPATCHA challenge. This allows unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. Note: The official PHP recommendation is not to pass untrusted input to unserialize even if the allowed_classes option is set to false.



Vulnerability Details for Anti-Spam: Spam Protection | Block Spam Users, Comments, Forms

Software Type Plugin
Software Slug stop-spammer-registrations-plugin (view on
Patched? Yes
Remediation Update to version 2022.6, or a newer patched version
Affected Version
  • <= 2022.5
Patched Version
  • 2022.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.