Accept Stripe Payments <= 2.0.79 - Unauthenticated Content Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2023-48285
CVSS 5.3 (Medium)
Publicly Published November 23, 2023
Last Updated January 22, 2024
Researcher Joshua Chan


The Accept Stripe Payments plugin for WordPress is vulnerable to Content Injection in all versions up to, and including, 2.0.79. This is due to payment data not properly being sanitized in the get_billing_details() function. This makes it possible for unauthenticated attackers to inject arbitrary content into pages.



Vulnerability Details for Accept Stripe Payments

Software Type Plugin
Software Slug stripe-payments (view on
Patched? Yes
Remediation Update to version 2.0.80, or a newer patched version
Affected Version
  • <= 2.0.79
Patched Version
  • 2.0.80

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.