Support Genix <= 1.2.3 - Missing Authorization

Missing Authorization
CVE CVE-2023-49742
CVSS 5.3 (Medium)
Publicly Published April 16, 2024
Last Updated April 25, 2024
Researcher beluga


The Support Genix plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several functions in all versions up to, and including, 1.2.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform unauthorized actions such as uploading arbitrary files.



Vulnerability Details for Support Genix – Support Tickets Managing System & Helpdesk Plugin for WordPress and WooCommerce

Software Type Plugin
Software Slug support-genix-lite (view on
Patched? Yes
Remediation Update to version 1.2.4, or a newer patched version
Affected Version
  • <= 1.2.3
Patched Version
  • 1.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.