SupportCandy <= 2.2.6 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24878
CVSS 6.1 (Medium)
Publicly Published January 5, 2022
Last Updated January 22, 2024
Researcher apple502j

Description

The SupportCandy WordPress plugin before 2.2.7 does not sanitise and escape the query string before outputting it back in pages with the [wpsc_create_ticket] shortcode embed, leading to a Reflected Cross-Site Scripting issue

Wordfence blocked 26 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for SupportCandy – Helpdesk & Customer Support Ticket System

Software Type Plugin
Software Slug supportcandy (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.7, or a newer patched version
Affected Version
  • <= 2.2.6
Patched Version
  • 2.2.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation