SupportCandy <= 2.2.6 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24878
CVSS 6.1 (Medium)
Publicly Published January 5, 2022
Last Updated January 17, 2023
Researcher apple502j


The SupportCandy WordPress plugin before 2.2.7 does not sanitise and escape the query string before outputting it back in pages with the [wpsc_create_ticket] shortcode embed, leading to a Reflected Cross-Site Scripting issue

Wordfence blocked 7 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug supportcandy (view on
Patched? Yes
Remediation Update to version 2.2.7, or a newer patched version
Affected Version
  • <= 2.2.6
Patched Version
  • 2.2.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.