SupportCandy <= 3.1.6 - Authenticated (Admin+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-2805
CVSS 7.2 (High)
Publicly Published May 22, 2023
Last Updated May 30, 2023
Researcher dc11


The SupportCandy plugin for WordPress is vulnerable to SQL injection via the 'agents[]' parameter used in the set_add_agent_leaves AJAX action in versions up to, and including, 3.1.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for SupportCandy – Helpdesk & Customer Support Ticket System

Software Type Plugin
Software Slug supportcandy (view on
Patched? Yes
Remediation Update to version 3.1.7, or a newer patched version
Affected Version
  • <= 3.1.6
Patched Version
  • 3.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.