Survey Maker – Best WordPress Survey Plugin <= 1.5.5 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 6.1 (Medium)
Publicly Published June 29, 2021
Last Updated January 31, 2023
Researcher WPScanTeam - WPScan


The Survey Maker plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via several parameters in versions up to, and including, 1.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for Survey Maker – Customer Satisfaction Questionnaire, Chat Survey, Calculation Form, Payment Forms

Software Type Plugin
Software Slug survey-maker (view on
Patched? Yes
Remediation Update to version 1.5.6, or a newer patched version
Affected Version
  • <= 1.5.5
Patched Version
  • 1.5.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.