tagDiv Composer < 3.5 - Unauthorized Account Access and Privilege Escalation

9.8
Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2022-3477
CVSS 9.8 (Critical)
Publicly Published October 24, 2022
Last Updated November 23, 2022
Researcher Truoc Phan - Techlab Corporation

Description

The tagDiv Composer plugin for WordPress is vulnerable to Unauthorized Account Access and Privilege Escalation in versions up to, but not including, 3.5 due to improper implementation of the Facebook login feature. This allows unauthenticated attackers to log in as any user as long as they know the user's email address. This plugin is used in several themes such as Newspaper and Newsmag.

Wordfence blocked 2 attacks targeting this vulnerability in the past 24 hours.

References

Share

3 affected software packages

Software Type Theme
Software Slug newsmag
Patched? Yes
Remediation Update to version 5.2.2, or a newer patched version
Affected Version
  • <= 5.2.1
Patched Version
  • 5.2.2
Software Type Theme
Software Slug newspaper
Patched? Yes
Remediation Update to version 12.1, or a newer patched version
Affected Version
  • <= 12
Patched Version
  • 12.1
Software Type Plugin
Software Slug td-composer (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.5, or a newer patched version
Affected Version
  • < 3.5
Patched Version
  • 3.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation