Template Kit – Import <= 1.0.14 - Authenticated(Author+) Stored Cross-Site Scripting via template upload

Unrestricted Upload of File with Dangerous Type
CVE CVE-2024-2334
CVSS 6.4 (Medium)
Publicly Published April 1, 2024
Last Updated April 9, 2024
Researcher Colin Xu


The Template Kit – Import plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the template upload functionality in all versions up to, and including, 1.0.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Template Kit – Import

Software Type Plugin
Software Slug template-kit-import (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.15, or a newer patched version
Affected Version
  • <= 1.0.14
Patched Version
  • 1.0.15

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.