Templately <= 2.2.5 - Improper Authorization to Arbitrary Post Deletion

Improper Authorization
CVE CVE-2023-5454
CVSS 6.5 (Medium)
Publicly Published October 16, 2023
Last Updated October 17, 2023
Researcher Krzysztof Zając - CERT PL


The Templately plugin for WordPress is vulnerable to unauthorized loss of data due to an improper capability check on the 'delete' REST endpoint in versions up to, and including, 2.2.5. This makes it possible for authenticated attackers to delete arbitrary posts.



1 affected software package

Software Type Plugin
Software Slug templately (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.6, or a newer patched version
Affected Version
  • <= 2.2.5
Patched Version
  • 2.2.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.