WP Testimonials <= 1.4.2 - Cross-Site Request Forgery to Widget Deletion

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2830
CVSS 4.3 (Medium)
Publicly Published July 14, 2023
Last Updated January 22, 2024
Researcher Skalucy


The WP Testimonials plugin for WordPress is vulnerable to Cross-Site Request Forgery due to a missing nonce check in the tabs/index-widget-header.php file in versions up to, and including, 1.4.2. This makes it possible for unauthenticated attackers to delete widgets via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP Testimonials

Software Type Plugin
Software Slug testimonial-widgets (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.4.3, or a newer patched version
Affected Version
  • < 1.4.3
Patched Version
  • 1.4.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.