The Moneytizer <= 9.6.3 - Missing Authorization via multiple AJAX actions

Improper Access Control
CVE CVE-2023-6966
CVSS 8.1 (High)
Publicly Published June 5, 2024
Last Updated July 1, 2024
Researcher Francesco Carlucci


The The Moneytizer plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to a missing capability check on multiple AJAX functions in the /core/core_ajax.php file in all versions up to, and including, 9.6.3. This makes it possible for authenticated attackers, with subscriber access and above, to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions.



Vulnerability Details for The Moneytizer

Software Type Plugin
Software Slug the-moneytizer (view on
Patched? Yes
Remediation Update to version 10.0.1, or a newer patched version
Affected Version
  • <= 9.6.3
Patched Version
  • 10.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.