Orbit Fox by ThemeIsle <= 2.6.3 - Improper REST Capabilities Checks

Missing Authorization
CVSS 7.3 (High)
Publicly Published November 12, 2018
Last Updated December 5, 2022
Researcher James Golovich


The Orbit Fox by ThemeIsle plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on several REST API endpoints in versions up to, and including, 2.6.3. This makes it possible for unauthenticated attackers to perform unauthorized actions such as uploading arbitrary files that can be used for remote code execution.

Wordfence blocked 4 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug themeisle-companion (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.4, or a newer patched version
Affected Version
  • <= 2.6.3
Patched Version
  • 2.6.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.