Orbit Fox Companion <= 2.10.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via custom fields

Improper Input Validation
CVE CVE-2023-6781
CVSS 6.4 (Medium)
Publicly Published January 5, 2024
Last Updated January 22, 2024
Researcher Nex Team


The Orbit Fox by ThemeIsle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's custom fields in all versions up to, and including, 2.10.26 due to insufficient input sanitization and output escaping on user supplied values. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Orbit Fox by ThemeIsle

Software Type Plugin
Software Slug themeisle-companion (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.10.27, or a newer patched version
Affected Version
  • <= 2.10.26
Patched Version
  • 2.10.27

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.