OpenHook <= 4.3.0 - Authenticated (Subscriber+) Remote Code Execution via Shortcode

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2023-5201
CVSS 9.9 (Critical)
Publicly Published September 29, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The OpenHook plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 4.3.0 via the 'php' shortcode. This allows authenticated attackers with subscriber-level permissions or above, to execute code on the server. This requires the [php] shortcode setting to be enabled on the vulnerable site.

Wordfence blocked 1,031 attacks targeting this vulnerability in the past 24 hours.



Vulnerability Details for OpenHook

Software Type Plugin
Software Slug thesis-openhook (view on
Patched? Yes
Remediation Update to version 4.3.1, or a newer patched version
Affected Version
  • <= 4.3.0
Patched Version
  • 4.3.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.