Top 10 <= 3.3.2 - Cross-Site Request Forgery via edit_count_ajax

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published November 3, 2023
Last Updated November 13, 2023
Researcher Brandon James Roldan (tomorrowisnew)


The Top 10 – WordPress Popular posts by WebberZone plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.3.2. This is due to missing or incorrect nonce validation on the 'edit_count_ajax' function. This makes it possible for unauthenticated attackers to edit post counts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug top-10 (view on
Patched? Yes
Remediation Update to version 3.3.3, or a newer patched version
Affected Version
  • <= 3.3.2
Patched Version
  • 3.3.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.