Top 10 – Popular posts plugin for WordPress <= 3.2.3 - Cross-Site Request Forgery via tptn_ajax_clearcache

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published February 20, 2023
Last Updated February 20, 2023


The Top 10 – Popular posts plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.2.3. This is due to missing or incorrect nonce validation on the tptn_ajax_clearcache function. This makes it possible for unauthenticated attackers to clear the plugin's cache via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Top 10 – WordPress Popular posts by WebberZone

Software Type Plugin
Software Slug top-10 (view on
Patched? Yes
Remediation Update to version 3.2.4, or a newer patched version
Affected Version
  • <= 3.2.3
Patched Version
  • 3.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.