Top 10 – Popular posts plugin for WordPress <= 3.2.3 - Missing Authorization on tptn_ajax_clearcache

Missing Authorization
CVE CVE-2023-25993
CVSS 4.3 (Medium)
Publicly Published February 20, 2023
Last Updated February 22, 2023
Researcher Rafshanzani Suhada


The Top 10 – Popular posts plugin for WordPress is vulnerable to unauthorized cache deletion due to a missing capability check on the tptn_ajax_clearcache function in versions up to, and including, 3.2.3. This makes it possible for authenticated attackers with subscriber-level access to delete the plugin's cache.



1 affected software package

Software Type Plugin
Software Slug top-10 (view on
Patched? Yes
Remediation Update to version 3.2.4, or a newer patched version
Affected Version
  • <= 3.2.3
Patched Version
  • 3.2.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.