TPG Redirect <= 1.0.7 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-32093
CVSS 4.3 (Medium)
Publicly Published May 31, 2023
Last Updated September 21, 2023
Researcher Taihei Shimamine


The TPG Redirect plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.7. This is due to missing or incorrect nonce validation on the tpg_rd_show_settings() function. This makes it possible for unauthenticated attackers to invoke this function and modify the plugin's settings and arbitrary options via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug tpg-redirect (view on
Patched? Yes
Remediation Update to version 1.0.8, or a newer patched version
Affected Version
  • <= 1.0.7
Patched Version
  • 1.0.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.