Spectra <= 2.6.6 - Authenticated (Contributor+) Server-Side Request Forgery in import_wpforms

Server-Side Request Forgery (SSRF)
CVE CVE-2023-36679
CVSS 8.5 (High)
Publicly Published July 14, 2023
Last Updated July 17, 2023
Researcher Rafie Muhammad - Patchstack


The Spectra plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 2.6.6 via the import_wpforms function. This can allow authenticated attackers, with contributor-level permissions and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Spectra – WordPress Gutenberg Blocks

Software Type Plugin
Software Slug ultimate-addons-for-gutenberg (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.7, or a newer patched version
Affected Version
  • <= 2.6.6
Patched Version
  • 2.6.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.