Spectra – WordPress Gutenberg Blocks <= 1.14.11 - Authenticated (Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2020-36656
CVSS 6.1 (Medium)
Publicly Published January 24, 2023
Last Updated February 3, 2023
Researcher István Márton - Wordfence


The Spectra – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 1.14.11 due to insufficient sanitizing of input in Gutenberg blocks. This makes it possible for contributors, or higher privileged users, to inject arbitrary web scripts that execute in a victim's browser.



Vulnerability Details for Spectra – WordPress Gutenberg Blocks

Software Type Plugin
Software Slug ultimate-addons-for-gutenberg (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.15.0, or a newer patched version
Affected Version
  • <= 1.14.11
Patched Version
  • 1.15.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.