Spectra – WordPress Gutenberg Blocks <= 1.14.7 - Missing Authorization

Missing Authorization
CVE CVE-2020-36702
CVSS 5.5 (Medium)
Publicly Published March 30, 2020
Last Updated January 22, 2024
Researcher Jerome Bruandet - NinTechNet


The Ultimate Addons for Gutenberg plugin for WordPress is vulnerable to Authenticated Settings Change in versions up to, and including, 1.14.7. This is due to missing capability checks on several AJAX actions. This makes it possible for authenticated attackers with subscriber+ roles to update the plugin's settings.



Vulnerability Details for Spectra – WordPress Gutenberg Blocks

Software Type Plugin
Software Slug ultimate-addons-for-gutenberg (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.14.8, or a newer patched version
Affected Version
  • <= 1.14.7
Patched Version
  • 1.14.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.