Ultimate Member <= 2.6.6 - Privilege Escalation via Arbitrary User Meta Updates

9.8
Incorrect Privilege Assignment
CVE CVE-2023-3460
CVSS 9.8 (Critical)
Publicly Published June 29, 2023
Last Updated January 22, 2024
Researcher Marc-Alexandre Montpas

Description

The Ultimate Member plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.6.6. This is due to the plugin using a predefined list of user meta keys that are banned which can be bypassed via a few method like adding slashes to the user meta key. This makes it possible for unauthenticated attackers to register on a site as an administrator.

Wordfence blocked 699 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin

Software Type Plugin
Software Slug ultimate-member (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.7, or a newer patched version
Affected Version
  • <= 2.6.6
Patched Version
  • 2.6.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation