Ultimate Reviews <= 3.2.8 - Unauthenticated stored Cross-Site Scripting via reviews

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-25597
CVSS 6.1 (Medium)
Publicly Published February 12, 2024
Last Updated February 14, 2024
Researcher Kang SeoHee


The Ultimate Reviews plugin for WordPress is vulnerable to stored Cross-Site Scripting via the review functionality in versions up to, and including, 3.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Ultimate Reviews

Software Type Plugin
Software Slug ultimate-reviews (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.9, or a newer patched version
Affected Version
  • <= 3.2.8
Patched Version
  • 3.2.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.