Unite Gallery Lite <= 1.7.59 - Authenticated(Administrator+) Local File Inclusion via 'view' parameter

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-33310
CVSS 5.0 (Medium)
Publicly Published May 22, 2023
Last Updated May 26, 2023
Researcher yuyudhn


The Unite Gallery Lite plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 1.7.59 via the 'view' parameter. This allows authenticated attackers with administrator-level privileges to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.



1 affected software package

Software Type Plugin
Software Slug unite-gallery-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.7.60, or a newer patched version
Affected Version
  • <= 1.7.59
Patched Version
  • 1.7.60

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.