Unlimited Elements for Elementor <= 1.5.107 - Authenticated (Contributor+) SQL Injection via data[post_ids][0]

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2024-4779
CVSS 8.8 (High)
Publicly Published May 22, 2024
Last Updated May 23, 2024
Researcher M.Awad


The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to SQL Injection via the ‘data[post_ids][0]’ parameter in all versions up to, and including, 1.5.107 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Unlimited Elements For Elementor (Free Widgets, Addons, Templates)

Software Type Plugin
Software Slug unlimited-elements-for-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.108, or a newer patched version
Affected Version
  • <= 1.5.107
Patched Version
  • 1.5.108

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.