Unlimited Elements For Elementor <= 1.5.96 - Authenticated (Contributor+) Stored Cross-Site Scripting via Widget Link

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-0367
CVSS 6.4 (Medium)
Publicly Published March 29, 2024
Last Updated March 30, 2024
Researcher Webbernaut


The Unlimited Elements For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the link field of an installed widget (e.g., 'Button Link') in all versions up to, and including, 1.5.96 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



1 affected software package

Software Type Plugin
Software Slug unlimited-elements-for-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.97, or a newer patched version
Affected Version
  • <= 1.5.96
Patched Version
  • 1.5.97

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.