UpdraftPlus <= 1.23.3 - Cross-Site Request Forgery to Cross-Site Scripting via action_authenticate_storage

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-32960
CVSS 6.1 (Medium)
Publicly Published May 18, 2023
Last Updated May 22, 2023
Researcher Rafie Muhammad - Patchstack


The UpdraftPlus plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.23.3. This is due to missing or incorrect nonce validation on the action_authenticate_storage function. This makes it possible for unauthenticated attackers to inject JavaScript into a parameter in the authentication process via a forged request which will execute in their browser at another part of the process, granted they can trick a site administrator into performing multiple actions including re-authenticating a connection to storage.



Vulnerability Details for UpdraftPlus: WP Backup & Migration Plugin

Software Type Plugin
Software Slug updraftplus (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.23.4, or a newer patched version
Affected Version
  • <= 1.23.3
Patched Version
  • 1.23.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.