Welcart e-Commerce < 2.2.8 - Missing Capabilities Check to Information Disclosure

Missing Authorization
CVE CVE-2021-4355
CVSS 7.5 (High)
Publicly Published August 6, 2021
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The Welcart e-Commerce plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on the download_orderdetail_list(), change_orderlist(), and download_member_list() functions called via admin_init hooks in versions up to, and including, 2.2.7. This makes it possible for unauthenticated attackers to download lists of members, products and orders.



Vulnerability Details for Welcart e-Commerce

Software Type Plugin
Software Slug usc-e-shop (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.8, or a newer patched version
Affected Version
  • < 2.2.8
Patched Version
  • 2.2.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.