Welcart e-Commerce <= 2.9.6 - Authenticated (Administrator+) Directory Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-6120
CVSS 4.1 (Medium)
Publicly Published December 8, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The Welcart e-Commerce plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.9.6 via the upload_certificate_file function. This makes it possible for administrators to upload .pem or .crt files to arbitrary locations on the server.



1 affected software package

Software Type Plugin
Software Slug usc-e-shop (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.9.7, or a newer patched version
Affected Version
  • <= 2.9.6
Patched Version
  • 2.9.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.