User Avatar <= 1.4.11 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-46621
CVSS 6.1 (Medium)
Publicly Published October 25, 2023
Last Updated November 22, 2023
Researcher Nguyen Xuan Chien


The User Avatar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'uid' parameter in versions up to, and including, 1.4.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



1 affected software package

Software Type Plugin
Software Slug user-avatar (view on
Patched? Yes
Remediation Update to version 1.4.12, or a newer patched version
Affected Version
  • <= 1.4.11
Patched Version
  • 1.4.12

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.