User Registration <= 3.0.1 - Authenticated (Subscriber+) PHP Object Injection

8.8
Deserialization of Untrusted Data
CVE CVE-2023-3343
CVSS 8.8 (High)
Publicly Published June 29, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence

Description

The User Registration plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 3.0.1 via deserialization of untrusted input from the 'profile-pic-url' parameter. This allows authenticated attackers, with subscriber-level permissions and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

Wordfence blocked 1 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug user-registration (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.2, or a newer patched version
Affected Version
  • <= 3.0.1
Patched Version
  • 3.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation